注册 登录  
 加关注
查看详情
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

态度决定高度

英语,沟通,rhca,管理

 
 
 

日志

 
 

CentOS中简单用yum升级 Python 至2.6  

2011-11-16 09:56:17|  分类: linux |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |

CentOS 在当前最新的 5.6 版中,其 python 的版本依然比较落后,还是古老的 2.4。

但是有些程序需要 2.6 才跑得起来,编译安装的话,又太麻烦,而且不适合菜鸟使用。

下面就给出使用 yum 升级 python 至 2.6 的简单方案。

   1: rpm -Uvh http://download.fedora.redhat.com/pub/epel/5Server/i386/epel-release-5-4.noarch.rpm
   2: yum install libffi -y
   3: yum install python26 -y
   4: rm -f /usr/bin/python
   5: ln -s /usr/bin/python26 /usr/bin/python

如果是 64 位的 CentOS,则将上述第一句代码中的 i386 改为 x86_64 即可。

运行完毕后,此时系统默认的 python 已经是 2.6 版了。

然而,yum 是基于 python2.4 的,因此会出现故障。解决方法也很简单:

   1: nano /usr/bin/yum

将第一行末的 python 后加上 2.4,即将第一行改为:

#!/usr/bin/python2.4

这样,yum 依然使用 python 2.4 环境运行,一切恢复正常。

此时我们输入 python -V 即可看到当前的 python 版本:

   1: # python -V
   2: Python 2.6.5
  评论这张
 
阅读(1186)| 评论(0)
推荐 转载

历史上的今天

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2018